why did app stop working????!!

My app was working fine on my brand new 4th generation Apple TV and then it stopped. I’ve deleted it FOUR times and nothing! Anyone else having this problem?

1 Like

Their Apple TV is horrible. I’m trying to figure out how to get my money back. I’m done.

1 Like

Same here. It was slow responding on Friday, but played Titans and a couple eps of Teen Titans ok. I didn’t use it on Saturday, and then tried to use it yesterday and today and it hasn’t worked. Reinstalling and restarting the AppleTV hasn’t helped. It usually loads the main app screen partly or completely, and then doesn’t respond to input from the remote.

Airplay from the DC Universe app on my iPhone and iPad to the appleTV has worked fine, but it is a little annoying to have to it that way.


The Apple TV app needs to be fixed. Send in your complaints to their support page. Hopefully they are reading the threads on here as well.

I am also having this same exact problem.

It is beyond frustrating that the AppleTV app has stopped working. I’ve submitted a ticket to let them know I’m paying to see nothing right now.