I Can’t Read Comics!

I keep trying to read a comic story on this app, but Alfred keeps saying I cant, no matter the internet connection and the many times I’ve tried to contact DC. Can someone help me with this? I just want to read some comics.

Hey @BatmanFan2007! :wave: I’m sorry to hear you’re encountering this issue with the comic reader.

Are you encountering this issue with any comic you try to read or just specific ones? Additionally, are you encountering this issue across all devices (and internet browsers if you have tried outside the app)?

Please try the following troubleshooting steps to see if the issue persists:

  • Check the status of your DCUI subscription.
  • Log out and back into your DCUI account.
  • Uninstall and reinstall the DCUI app.
  • Clear your cache/cookies.
  • Use a different device and/or internet browser.

If you are still encountering this issue after the above steps, I would recommend reaching out to our Technical Support team here: Submit a request – DC Universe Help Center.

They’ll be able to better assist you than we community moderators can. :grinning_face_with_smiling_eyes:


Well it keeps happening with every comic I try to read. Every time Alfred just pops up and I can’t even get a glimpse of the comic I try to read. I’ll try though what you told me first, and I’ll let you know if it works.

Edit: Deleting and Reinstalling the app and it worked. Thanks for that. :+1: I say I might as well owe you something.


Happy to hear you’re reading comics again :grin:

Please let us know if you encounter any more issues!